freebsd-update cron
to
youe /etc/crontab
file. Chapter
26. Updating and Upgrading FreeBSD/home
lives. Home directories used to go
into /usr/home
, and upon first use, a link would be
created in /
to point there. Now they've changed it to
simply put them in /home
. Ok fine, what's the
problem?/
is fairly
small, it's basically just the bootable OS. Most everything else is
in larger partitions, e.g. /usr
which will swell over
time to contain packages and other such stuff. /home
can
also grow out of control, so it was appropriate to be
in /usr
or even it's whole own partition. (I never went
that far.)/home
, I just suddenly filled up my
main /
directory!/home
.cd /
mkdir /usr/home.new
tar -cf - -C /home . | tar -xpf - -C /usr/home.new
mv home home.bak
ln -s /usr/home home
cd /usr
mv home home.bak
mv home.new home
cd /usr/bin
ln -s /usr/local/bin/perl perl
cpan install Config::Simple
cpan install DateTime
pkg install curl
cpan install DateTime
cpan install DateTime::Format::Strptime
cd /usr/local/lib/perl/site_perl
cpan install HTTP::Date
cpan install Net::FTP::Throttle
cpan install URL::Encode
cpan install HTTP::Request
cpan install LWP
cpan install JSON
ftp over your backup files for 'root' and 'mikel'. 'tar' them into
place. Edit bin/aliases to replace the xterm/xload alias color.
Clean up cronfile for both of these guys, and do crontab
cronfile
for each.
pkg install bind918
sysrc named_enable="YES"
cd /etc
ln -s /usr/local/etc/namedb namedb
(I've spent many years going to /etc/namedb)
cd namedb
rndc-confgen -a
Bring over master file from old system, and do merge.
So starting over, again. Boot from external HD, install doing the mfi magic described below.
For some reason giving DNS as my DSL modem gateway is not working, even though it's working fine on another FreeBSD12.4 system... Who knows, got things working by using the external CenturyLink DNS server 205.171.3.65.
Now to install 'pkg':
pkg
Then the goal is to get remote access ASAP:
pkg install xorg-minimal
(yes, this was sufficient)
pkg install xterm
pkg install xload
Use 'vi' to edit /etc/rc.conf
, and add the line:
sshd_flags="-o X11Forwarding=yes"
Note that you'll be changing it to the following once you've installed blacklistd:
sshd_flags="-o X11Forwarding=yes -o UseBlackListd=yes"
While you're there:
ftd_flags="-B -D"
Then:
service sshd restart
If you already had an 'ssh'
session going, you'll need to close it. Now go back in and xterm and
xload should work. Of course you'll need to do the
standard
setenv DISPLAY localhost:10.0
Be sure to add your personal user account to /etc/group
on the root
line so as to allow 'su' from 'ssh'.
Do vipw
and replace that stupid "Charlie" name in the
root user with the system name.
As of FreeBSD14, the default shell for 'root' is now 'sh', you'll want
to correct this with chsh -s tcsh
I realized that the new disk was not yet mounted, so I decided to get
that going before investing any more time updating in case it went
all wrong and I had to reinstall again.
mkdir /dsk2
mount /dev/da1 /dsk2
gives an error, sorry, I've forgotten it already. Maybe it needs to be formatted?
newfs -f 8192 -b 65536 /dev/da1
Now 'mount' again - all is well.
Edit /etc/fstab
, add:
/dev/da1 /dsk2 ufs rw 2 2
then do:
mount -u
Hopefully this would give you a barf if you've messed up 'fstab' - you
can brick your system with 'fstab' screwups.
pkg install spamassassin
/etc/rc.conf
including chg user to spamd
.pkg install spamass-milter
ln -s /usr/local/bin/perl /usr/bin/perl
cpan install HTTP::Date
cpan install Config::Simple
cd /usr/local/lib/perl5/site_perl
. Copy in your VN* files.cpan install Net::FTP::Throttle
fetch: https://www.ietf.org/timezones/data/leap-seconds.list: Not Found
/etc/rc.conf
:ntp_leapfile_sources: ftp://ftp.boulder.nist.gov/pub/time/leap-seconds.list
(forum post)CPU
support Enhanced Speedstep, but is not recognized
".
(forum
post)pkg install sendmail
cd /usr/local/lib/sasl2
Sendmail.conf
make sure it has pwcheck correct.service saslauthd start
ps ax | grep sasl
cd /usr/local/etc/mail
cp mail.conf.sendmail mail.conf
service sendmail start
ps ax | grep sendmail
pkg search bind
- Current latest is 9.18pkg install bind918
ln -s /usr/local/etc/namedb /etc/namedb
- this is the old location, makes it easier for me to find it/usr/local/sbin/rndc-confgen -a
set hw.mfi.mrsas_enable=1
boot
cd /boot
cp loader.conf loader.conf.bak
vi
to edit loader.conf
. Add the line:hw.mfi.mrsas_enable=1
cd /etc
cat
to confirm that fstab
and rc.conf
mention "da0" not "mfi0". If the latter,
use vi
to change itexit
then take reboot option.xorg-minimal
but did not get a
functional window back, just the worthless "Error: can't open display"
message. Install full "xorg", still no good. Closed out my ssh
session, went back in and now it's working. I don't know if -minimal
would have sufficed, I'll try that again next time. (See comments above 20240205.)
So edit /etc/fstab
and replace all references to
'mfi0
' with 'da0
'. Then
edit /boot/loader.conf
and add the
line hw.mfi.mrsas_enable=1
. It also says to do the
replace in /etc/rc.conf
, but I had nothing to change.
I'm now booted into the system, we'll keep an eye out for that
error in the future. (Couple days later - not seeing any disk errors,
looks like it worked.)
I'm paranoid about the error I originally got when installing - it seems to me that there's a bad file on the disk somewhere that I may or may not ever hit, so I'm going to reinstall afresh again, this time using the 'da' drivers - I got advice from the forums.freebsd.org forum. See above for details.
Finally got this figured out, if I had read the release notes I would
have had the answer... New with FreeBSD14, you'll need to
do:
sysrc sshd_flags="-o
X11Forwarding=yes"
BTW: If you do this manually (editing /etc/rc.conf
), when
done, do sysrc -a
which does a syntax check. Errors in
this file can leave you with an unbootable system.
amd64
. I
have 3x 1Tb disks in a RAID5 configuration. (There was a fair amount
of work getting the IDRAC updated and updating, I did not document it,
sorry. I was able to get IDRAC to be able to handle updating the
server though, it is worth doing the updates to get it there.) (While
you're in IDRAC, see BIOS settings above 20231222.)
I did not find an option to boot from USB, so I went with the DVD
option. Downloaded FreeBSD-14.0-RELEASE-amd64-dvd.iso
onto Win11 desktop machine. Right-clicked on filename, took "burn
image" option.
Booted server to DVD. Deselected debug stuff,
selected src
and ports
. Took manual
partitioning with MBR
. It took the liberty of creating a
boot partition of 512MB.
16GB freebsd-ufs /
64GB freebsd-ufs /tmp
4GB freebsd-swap
368GB freebsd-ufs /var
[remainder]GB freebsd-ufs /usr
This showed errors, and would not boot.
Went into Lifecycle Controller and selected OS Deployment. The "any other OS" option is a dead end, all options are grayed out. Tried selecting Windows server 2019, and selected my DVD in the drive - it did show up. Reboots and then boots from DVD. Looks the same as last time. This time I deleted all my previous partitions, and let it do auto, let's see if we get a bootable system this way.
As with previous attempt, I got a few "MFI0: failed to get command" errors. I don't know if this is a problem, but Yay! System now boots to FreeBSD! (see above 20231215)
I'm going to try again as I really want separate partitions, namely so
that /tmp will be alone, thus cannot overflow the rest of the disk. I
just booted the DVD again, and started again. This time however, due
to the mfi0 error in 'lib32' load, I'm skipping that. Also skipping
'src' and of course skipping any debug.
I went into "manual"
partition editing, deleted the main partition, leaving behind the 4G
swap auto had previously created, then created as list above.
Then gosub new install release 10